Helm deployments failing with older delegates. (< 25.05.858XX)

Incident Report for Harness

Postmortem

Following a recent release, Helm deployments began failing for customers in the Prod1 and Prod2 environments. The issue primarily affected pipelines running on Delegates with versions ≤ 856xx.

What was the issue?

A serialization incompatibility between the Manager and legacy Delegate versions (version 856xx and below) caused pipeline failures during Helm deployments.

Resolution

Upon identifying the issue, the engineering team immediately rolled back the Manager in both Prod1 and Prod2 to the previous stable version. This action restored pipeline functionality for all impacted customers.

Next Steps

  1. The engineering team has already undertaken work to be proactive by adding such serialization checks to catch compatibility issues with older Delegate versions.
  2. The team is also adding additional instrumentation and alerting to help surface and detect such deeper issues more effectively.
Posted Jun 25, 2025 - 21:50 PDT

Resolved

This incident has been resolved.
Posted May 30, 2025 - 03:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 02:35 PDT

Update

we restored system to previous version
Posted May 30, 2025 - 02:33 PDT

Identified

The issue has been identified.
Posted May 30, 2025 - 01:40 PDT

Update

We are currently investigating
Posted May 30, 2025 - 01:33 PDT

Investigating

Helm deployments failing with older delegates (< 25.05.858XX)
Posted May 30, 2025 - 01:23 PDT
This incident affected: Prod 2 (Continuous Delivery - Next Generation (CDNG)) and Prod 1 (Continuous Delivery - Next Generation (CDNG)).