Write operations (git push) not working for Harness Code in Prod 1

Incident Report for Harness

Postmortem

Summary

Between 10:38 AM and 11:54 AM PT on October 30, 2025, customers using Harness Code in Prod1 were unable to push or commit code.

A configuration issue in a recent deployment caused authentication failures for the code-service, preventing Git operations.

All other environments and services remained fully functional.

Root Cause

This was due to a misconfiguration in the Kubernetes ConfigMap, which caused the pulling of a secret from the wrong store. This misconfiguration broke the authentication and authorization flow for code-repository-service in Prod1, resulting in failed push and commit attempts.

Impact

  • Developers were unable to push or commit code to Harness Code in Prod1 during the incident window.
  • Other environments and services were unaffected.

Remediation

  • Immediate: Corrected secret reference to the Prod1 store and redeployed the code-service.
  • Permanent: Enforced validation and sanity checks in the deployment pipeline to verify environment-specific secret configurations before rollout.

Action Items

Posted Nov 03, 2025 - 10:58 PST

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 12:02 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 11:58 PDT

Investigating

We are currently investigating this issue.
Posted Oct 30, 2025 - 11:57 PDT
This incident affected: Prod 1 (Code Repository).