CCM: When adding labels to cluster table dashboards, certain fields are removed limiting cost visibility to the cluster costs.

Incident Report for Harness

Postmortem

Summary

 

Between Aug 15, 2025 - 10:50 PDT and Aug 16, 2025 - 14:33 PDT customers were unable to use the Cluster cost and utilization dashboards. All other areas were unaffected.

Root Cause

The team inadvertently introduced a bug during the implementation of a new Looker feature. This bug was caused during updating dynamic_instancetype_filter condition. 

Impact

Users encountered issues when attempting to access the Cluster cost and utilization dashboards.

Remediation

  • The team deployed an updated build with fix.

Action Items

In order to prevent a recurrance of such issues we are enhancing our testing framework and coverage to add test around these usecases (Ex. instance type filter)

Posted Sep 22, 2025 - 18:09 PDT

Resolved

This incident is resolved
Posted Aug 16, 2025 - 14:33 PDT

Update

we are investigating potential issues with budget alerts not behaving as expected. more information to follow
Posted Aug 15, 2025 - 15:32 PDT

Identified

The fix is in place
Posted Aug 15, 2025 - 10:50 PDT
This incident affected: Prod 4 (Cloud Cost Management (CCM)), Prod 1 (Cloud Cost Management (CCM)), Prod 2 (Cloud Cost Management (CCM)), Prod 3 (Cloud Cost Management (CCM)), and Prod Eu1 (Cloud Cost Management (CCM)).