Prod 2 - Customers may see some executions from March 11 in a "running" but hung state

Incident Report for Harness

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 12:16 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 12, 2026 - 09:21 PDT

Investigating

Customers may continue to see that some pipeline executions show that they are "running" even though they have completed, aborted, or failed as a result of yesterday's incident. (https://status.harness.io/incidents/4y4dl47v2qhc)

This behavior is a UI-only artifact from the incident and should not affect customers' ability to start new executions.  We are working on clearing these artifacts.
Posted Mar 12, 2026 - 09:20 PDT
This incident affected: Prod 2 (Continuous Delivery - Next Generation (CDNG)).