CG Secret manager is broken in Prod-2
Incident Report for Harness
Postmortem

Summary

A few trial Current Gen(CG) CD customers had difficulty Login and accessing Harness Secret Manager in our Prod-2 environment. There was no impact on Next Gen(NG) customers.

Timeline

Time (UTC) Event
04:22 am We received internal alerts for an increased error rate related to Secret Manager.
06:09 am An incident was raised when a trial customer reached out.
06:28 am The root cause was identified.
07:34 am Incident was resolved

Resolution

Upon referencing the code base, we identified a key configuration missing in our database records. The required data was restored from periodic snapshots.

RCA

As a part of the official EOL for CG CD, a cleanup activity in the backend database for all internal accounts was done. In the cleanup process, a legacy configuration which the Harness Secret Manager used was deleted.

Action Items

We will perform stringent checks on data before cleanup, followed by sanity to ensure no functionality gets impacted.

Posted May 06, 2024 - 00:03 PDT

Resolved
The issue with CG Secret manager has been resolved for all customers as of May 03, 2024 - 00:10 PDT. We thank you for your patience while we worked in resolving the issue.
Posted May 03, 2024 - 00:22 PDT
Monitoring
Our engineering team has resolved the issue , We are actively monitoring the issue.
Posted May 03, 2024 - 00:10 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 02, 2024 - 23:19 PDT
This incident affected: Prod 2 (Continuous Delivery (CD) - FirstGen - EOS).