Degraded performance in CI Steps in Prod 2 and Prod 3

Incident Report for Harness

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 10:34 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2026 - 09:27 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2026 - 09:16 PDT

Investigating

We are noticing degraded performance in CI Steps in Prod 2 and Prod 3 environments
The issue is intermittent. We are investigating the cause
Posted Mar 13, 2026 - 09:12 PDT
This incident affected: Prod 3 (Continuous Integration Enterprise(CIE) - Mac Cloud Builds, Continuous Integration Enterprise(CIE) - Windows Cloud Builds, Continuous Integration Enterprise(CIE) - Linux Cloud Builds) and Prod 2 (Continuous Integration Enterprise(CIE) - Mac Cloud Builds, Continuous Integration Enterprise(CIE) - Windows Cloud Builds, Continuous Integration Enterprise(CIE) - Linux Cloud Builds).