Autostopping service degraded in AWS (Middle East South 1)

Incident Report for Harness

Monitoring

Update:
AutoStopping functionality for AWS has been restored for all regions except me-south-1.
The issue was caused by elevated latency from AWS in the affected region, impacting operations such as warm-up, cool-down, schedule execution, and traffic detection. We have now isolated this region to prevent impact on other customers.
Resources in me-south-1 will continue to experience the issue until the region fully recovers. We are actively monitoring the situation and will provide further updates as available.
Posted Apr 01, 2026 - 01:20 PDT

Update

Status update :
CCM AutoStopping functionality for the AWS cloud provider is currently impacted due to increased latency from AWS in the me-south-1 region. This is affecting multiple operations, including warm-up, cool-down, schedule execution, and traffic detection.
In addition, CCM Asset Governance functionality is also impacted for resources in the me-south-1 region.

We are actively working on isolating/excluding the affected region to restore functionality for the remaining customers. Resources within the me-south-1 region may continue to experience issues until the region fully recovers.
Posted Mar 31, 2026 - 23:44 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 31, 2026 - 23:16 PDT
This incident affects: Prod 1 (Cloud Cost Management (CCM)), Prod 2 (Cloud Cost Management (CCM)), and Prod 3 (Cloud Cost Management (CCM)).