The IDP app is currently facing accessibility issues

Incident Report for Harness

Postmortem

Summary

On April 7, 2026, customers using the Internal Developer Portal (IDP) in certain production environments experienced service disruption where the IDP UI became inaccessible. Users encountered errors when attempting to access the module.

Root Cause

A configuration change introduced during a routine deployment prevented the system from correctly routing incoming requests to the IDP service, resulting in loss of access to the UI.

Impact

Customers using IDP in affected environments were unable to access the portal UI during the incident window. Other modules and environments remained unaffected.

Remediation

Immediate:

Rolled back the recent configuration change and restored service routing, which recovered access to the IDP module.

Permanent:

Implemented additional safeguards in the deployment process to validate configuration changes and ensure compatibility before rollout.

Action Items

To prevent such issues from happening again, we are taking the following steps.

  • Enhancing our release process and UI validation
  • Improve monitoring and alerting for early detection of routing issues
Posted Apr 21, 2026 - 06:00 PDT

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 04:08 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 07, 2026 - 03:59 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 03:54 PDT
This incident affected: Prod 4 (Internal Developer Portal (IDP)) and Prod Eu1 (Internal Developer Portal (IDP)).