Vercel Integration for FME is having delays to synchronize changes

Incident Report for Harness

Postmortem

Summary

On May 7, 2026, customers using the Vercel integration experienced delays in synchronizing Feature Management & Experimentation (FME) changes to Vercel. The issue was caused by a dependency update in the integration service that prevented outbound synchronization requests from being authenticated correctly. The issue was resolved on May 11, 2026 through a service fix and validation of synchronization workflows.  

Impact

  • Customers using the Vercel integration experienced delays propagating FME changes to Vercel
  • Customers observed stale configuration data in Vercel after updating changes in FME
  • Other FME functionality remained operational
  • No data loss occurred

Root Cause

A deployment to the integrations-service-v2 service introduced dependency updates that removed a required AWS SDK component used during request signing and authentication for synchronization calls.

As a result, outbound requests from the FME integration service to the synchronization endpoint could not be authenticated correctly, causing synchronization operations to fail.

The issue was not immediately detected because:

  • Existing monitoring metrics did not have alerting configured
  • The failure mode did not surface as a critical application startup error
  • Integration-level automated test coverage for this synchronization workflow was insufficient

Resolution

The missing dependency was restored and the synchronization workflow was validated across affected integrations. Monitoring and validation checks confirmed successful synchronization behavior after deployment.

Preventive Actions

To prevent such issues from happening again, We are implementing the following improvements:

  • Enhance end-to-end integration tests for the Vercel synchronization workflow
  • Enhance our proactive alerts for synchronization failures and elevated error rates
Posted May 12, 2026 - 18:55 PDT

Resolved

This incident has been resolved.
Posted May 11, 2026 - 16:15 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 11, 2026 - 15:42 PDT

Investigating

We are currently investigating this issue.
Posted May 11, 2026 - 15:42 PDT
This incident affected: Feature Management & Experimentation (FME) (Integrations).