Cloud builds are failing with 429 Too Many Requests error while downloading artifacts from central sonatype registry.

Incident Report for Harness

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 10:13 PDT

Update

We are continuing to monitor for any further issues.
Posted Jun 17, 2026 - 09:12 PDT

Update

Maven Central is rate-limiting requests originating from our us-central1 NAT egress IP. Other regions (us-west1, us-east5) are not affected. The Maven/Sonatype team has been engaged and is actively working on lifting the rate limit for our IP range.
Posted Jun 17, 2026 - 08:21 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2026 - 07:21 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 17, 2026 - 07:03 PDT

Investigating

We are investigating an issue affecting artifact downloads from Maven Central following recent rate-limiting changes implemented by Sonatype. Sonatype has recently implemented rate limits and builds downloading artifacts from central sonatype  https://central.sonatype.org/faq/429-contact-support/. Customers downloading artifacts would be impacted. 

We are actively engaging with Sonatype to mitigate the issue here.
Posted Jun 17, 2026 - 06:42 PDT
This incident affected: Prod 4 (Continuous Integration Enterprise(CIE) - Windows Cloud Builds, Continuous Integration Enterprise(CIE) - Linux Cloud Builds), Prod 3 (Continuous Integration Enterprise(CIE) - Windows Cloud Builds, Continuous Integration Enterprise(CIE) - Linux Cloud Builds), Prod 1 (Continuous Integration Enterprise(CIE) - Windows Cloud Builds, Continuous Integration Enterprise(CIE) - Linux Cloud Builds), and Prod 2 (Continuous Integration Enterprise(CIE) - Windows Cloud Builds, Continuous Integration Enterprise(CIE) - Linux Cloud Builds).