FME tile is not being displayed

Incident Report for Harness

Postmortem

Summary

  • On Jan 7, 2026 ,starting 13:55 UTC a limited number customers could not see the FME Module in the Harness UI. Issue was fully resolved at 19:34 UTC

Root Cause

  • A configuration change controlled visibility of the FME module tile in the Harness UI. The change relied on a stale list of account IDs. This caused the FME tile to be disabled for a small set of valid accounts

Impact

  • Harness Prod1 was the only affected clusters only affected limited number of customers. As a result of this configuration change, the FME Module tile was not displayed in the UI
  • Note: There were no issues with SDK evaluation or the FME flag delivery network and there was no data loss incurred as a result of this disruption

What was not impacted?

  • Admin API calls
  • Feature flag evaluations
  • FME flag delivery network or SDK traffic
  • Customer flag configuration data

Remediation

  • We reverted the Configuration change and Correct account list was applied. Thereby UI access restored for all impacted customers

Action Items

  • To prevent such issues from happening again, we are enhancing internal processes(testing and validations) to catch such issues early on.
Posted Jan 07, 2026 - 21:35 PST

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 14:35 PST

Monitoring

Service issues have been addressed and normal operations has been resumed. We are monitoring the service to ensure normal performance continues.
Posted Jan 07, 2026 - 09:17 PST

Investigating

FME Module UI inaccessible in prod 1 cluster
Posted Jan 07, 2026 - 09:09 PST
This incident affected: Feature Management & Experimentation (FME) (Management Console).