FME SDKs - SDKs falling back to polling

Incident Report for Harness

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 09:38 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2026 - 08:13 PDT

Identified

Instability in streaming connections could cause a delay in propagating updates. All SDKs are designed to poll against the CDN on streaming disconnects and instability scenarios.

This could also cause some noise in the logs as SDKs try to reconnect to streaming. But updates are unaffected.
Posted Jun 04, 2026 - 07:33 PDT
This incident affected: Feature Management & Experimentation (FME) (Streaming service).