Prod3 Pipeline UI Updates on execution graph slowness

Incident Report for Harness

Resolved

This incident has been resolved.
The incident was identified as a slowness on the UI updates for execution graph visualization. Executions were not impacted outside of the UI execution graph visualization.
Posted May 20, 2026 - 05:38 PDT

Monitoring

A fix has been implemented which resolved the pipeline slowness , we are currently monitoring the results.
Posted May 20, 2026 - 04:52 PDT

Investigating

We have received reports of slowness in Harness pipelines in Prod3 cluster. We are actively investigating this issue. Please monitor this space for further updates.
Posted May 20, 2026 - 03:48 PDT
This incident affected: Prod 3 (Continuous Delivery - Next Generation (CDNG), Infrastructure as Code Management (IaCM)).