GCP Billing Delay: Google Cloud is experiencing billing export delays

Incident Report for Harness

Postmortem

This was a issue with GCP cloud provider. Here is Google’s response:

We are writing to follow up on the technical issue reported on January 14, 2026, regarding delayed Billing data exports to BigQuery. We are pleased to confirm that this issue was resolved on January 18, 2026.What you need to know
The technical issue reported on January 14, 2026, has been resolved as of January 18, 2026. All delayed cost data is now available, and exports are functioning as expected.Thank you for your patience while we worked to fix this.

Posted Jan 20, 2026 - 19:28 PST

Resolved

This incident has been resolved.
Posted Jan 20, 2026 - 16:58 PST

Monitoring

GCP Billing Delay: Google Cloud is experiencing billing export delays since approximately January 10, which may result in incomplete cost data for some GCP resources.
Posted Jan 15, 2026 - 14:25 PST
This incident affected: Prod 4 (Cloud Cost Management (CCM)), Prod 1 (Cloud Cost Management (CCM)), Prod 2 (Cloud Cost Management (CCM)), and Prod 3 (Cloud Cost Management (CCM)).