Feature Management & Experimentation (FME) user interface unavailable

Incident Report for Harness

Postmortem

Summary

  • Starting at 23:42 UTC on August 23, 2026, several FME customers reported failures loading the FME UI.
  • FME UI Artifacts served from the CDN expired due to a retention policy, causing FME UI to fail to load.
  • Any flag request changes through the API, change delivery, and the data pipeline continued to work with no interruption.

Root Cause

  • The FME UI is served from a CDN. The UI artifacts got evicted due to a retention policy, causing the UI to fail to load for all users.

Impact

  • The FME UI was unable to load for all users across all production environments.

What was not impacted?

  • SDK functionality and runtime flag evaluation
  • Admin API calls
  • Customer flag configuration data
  • No data loss occurred

Remediation

  • FME UI got restored in the CDN through a deployment
  • Recovery confirmed across all production environments before closing the incident.

Action Items

  • Improve the asset retention policy so that the currently active version is never subject to eviction.
Posted Aug 27, 2026 - 16:37 PDT

Resolved

This incident has been resolved.
Posted Aug 23, 2026 - 18:12 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 23, 2026 - 18:08 PDT

Update

We are currently investigating reports that the Feature Management & Experimentation (FME) user interface is failing to load. Customers attempting to access the FME console may encounter errors or unresponsive pages. Feature flag evaluation and SDK traffic are not believed to be affected. A further update will follow shortly.
Posted Aug 23, 2026 - 18:01 PDT

Investigating

We are currently investigating this issue.
Posted Aug 23, 2026 - 17:57 PDT
This incident affected: Prod 1 (FME).