GCP Billing Delay - Google Cloud billing export delays since March 8 may cause incomplete cost data for GCP resources. Resolution by GCP is expected soon

Incident Report for Harness

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 00:13 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 00:33 PDT

Update

Google Cloud billing export delays since ~March 8 may cause incomplete cost data for GCP resources. Resolution by GCP is expected soon
Posted Mar 10, 2026 - 00:01 PDT

Identified

We are experiencing delays in GCP billing data due to an issue with the GCP Billing Export.
Posted Mar 09, 2026 - 03:47 PDT
This incident affected: Prod 4 (Cloud Cost Management (CCM)), Prod 1 (Cloud Cost Management (CCM)), Prod 2 (Cloud Cost Management (CCM)), Prod 3 (Cloud Cost Management (CCM)), and Prod Eu1 (Cloud Cost Management (CCM)).