FME UI errors on creating/updating Flags for subset of customers who have Jira integration.

Incident Report for Harness

Postmortem

Summary

On April 30, 2026, customers with the Jira Cloud integration configured were unable to create feature flags via the UI. The issue lasted approximately 3 hours and was resolved through a rollback followed by a permanent fix deployment the same day.

Impact

  • Feature flag creation in the UI failed for customers with the Jira Cloud integration installed and configured
  • Flag creation via API was not affected
  • Customers without the Jira integration were not affected
  • Existing feature flags, SDK evaluations, and all other platform functionality remained fully operational
  • No data loss occurred

Timeline

Time (UTC) Event
April 30, 13:07 Feature flag creation began failing for affected accounts
April 30, 15:31 Service rolled back, restoring functionality
April 30, 17:22 Identified root cause
April 30, 18:59 Permanent fix deployed and validated

Root Cause

A service update modified how user identity is resolved when retrieving data from configured integrations. During flag creation in the UI, the system calls out to the Jira integration to power the issue-linking feature on the creation page. Under the new logic, the identity context was unavailable for this outbound call, causing the flag creation flow to fail for accounts with the Jira Cloud integration configured.

The issue was limited to the UI creation path and did not affect API-based flag creation or any other platform operations.

Remediation

  • Immediate: Rolled back to the previous version, restoring feature flag creation for all affected customers.
  • Permanent: Deployed a fix that correctly resolves user identity when retrieving data from configured integrations.

Action Items

  • Improve resilience of integration paths so that failures when fetching data from connected integrations do not block core platform operations such as flag creation.
  • Expand automated test coverage for end-to-end scenarios involving configured integrations to prevent similar regressions.
Posted May 08, 2026 - 10:22 PDT

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 09:14 PDT

Investigating

We are currently investigating this issue.
Posted Apr 30, 2026 - 08:57 PDT
This incident affected: Prod 3 (FME), Prod 1 (FME), and Prod 2 (FME).