EU1: Codebase Expression Fails to Resolve in Pipelines Across Multiple Projects (Partial outage)

Incident Report for Harness

Resolved

Issue is resolved.
Posted May 20, 2025 - 08:52 PDT

Monitoring

Rolled back the deployment and customer confirms
Posted May 20, 2025 - 08:52 PDT

Identified

We are rolling back the deployment and validating
Posted May 20, 2025 - 08:35 PDT

Investigating

We are currently looking into an issue where codebase Expression is failing to Resolve in Pipelines Across Multiple Projects
Posted May 20, 2025 - 08:15 PDT
This incident affected: Prod Eu1 (Infrastructure as Code Management (IaCM)).