Intermittent External Network Connectivity Issues Affecting Build VMs

Incident Report for Harness

Postmortem

Summary

Starting on August 4, 2026, CI runners in the us-west1 and us-central1 regions intermittently experienced connection timeouts of approximately 134 seconds when reaching external services such as GitHub and Bitbucket over outbound network gateways.

Impact

  • CI runners in the affected regions intermittently experienced connection timeouts of approximately 134 seconds when reaching external services (e.g., GitHub, Bitbucket) over our outbound network gateways.
  • The issue was intermittent rather than constant — connections succeeded under normal load, and failures clustered during periods of high outbound traffic volume.
  • No data was lost or corrupted. This was a network-connectivity and capacity issue, not a data-integrity issue.
  • us-west1 and us-central1 were the affected regions; other regions were not impacted by this issue.

Root Cause

Our load balancer distributes outbound traffic across multiple NAT gateways using a hashing method based on connection details (source/destination address and port). For any single connection, these details stay constant for that connection's lifetime. We had a sustainted traffic surge for a few seconds which congested the gateways

Action Items

To prevent such issues from happening again Harness will,

Increase outbound connection capacity on our NAT gateways by provisioning additional external network interfaces, giving each gateway a substantially larger pool of connections it can serve concurrently..

Posted Aug 07, 2026 - 13:24 PDT

Resolved

This incident has been resolved.
Posted Jul 30, 2026 - 20:22 PDT

Update

We are continuing to monitor for any further issues.
Posted Jul 30, 2026 - 01:07 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 01:07 PDT

Investigating

Summary - We are intermittently facing network connectivity issues with our Build VM's unable to connect to external resources.
We are currently investigating the issue.
Posted Jul 29, 2026 - 22:59 PDT
This incident affected: Prod 4 (Continuous Integration Enterprise(CIE) - Linux Cloud Builds), Prod 3 (Continuous Integration Enterprise(CIE) - Linux Cloud Builds), Prod Eu 1 (Continuous Integration Enterprise(CIE) - Linux Cloud Builds), Prod 1 (Continuous Integration Enterprise(CIE) - Linux Cloud Builds), and Prod 2 (Continuous Integration Enterprise(CIE) - Linux Cloud Builds).