Harness overview dashboard is not loading on Prod-Eu1

Incident Report for Harness

Postmortem

Summary 

Following the core release on February 5th, the Overview Dashboard in the EU cluster experienced degraded functionality. Investigation revealed that a version mismatch between the newly released core service and the existing dashboard service caused compatibility issues, leading to the degradation.

Resolution

We deployed the latest released version of dashboard service to resolve the issue.

RCA

The Dashboard service relies on the core services for proper functionality. An updated version of the core services was updated without updating the Dashboard service, resulting in a failure of the Overview dashboard to operate as expected.

Action Item

We have implemented a check to ensure dashboard service is also updated when the dependencies are updated.

Posted Apr 23, 2025 - 11:45 PDT

Resolved

We have fixed the issue with Overview dashboard/landing dashboard. This incident is resolved now. Please monitor this page for postmortem report.
Posted Feb 05, 2025 - 09:08 PST

Identified

We have identified a potential cause of the service issues and are working hard to address it. Please continue to monitor this page for updates.
Posted Feb 05, 2025 - 07:24 PST

Investigating

We are currently investigating this issue.
Posted Feb 05, 2025 - 02:30 PST
This incident affected: Prod Eu1 (Continuous Delivery - Next Generation (CDNG)).