IACM infrastructure pipelines using terraform are currently experiencing an outage

Incident Report for Harness

Resolved

This incident has been resolved.

Customers using a pinned version older than plugins/harness_terraform:0.214.0 should update to the latest version by following the
https://developer.harness.io/docs/continuous-integration/use-ci/set-up-build-infrastructure/harness-ci/#specify-the-harness-ci-images-used-in-your-pipelines.

If you are not pinning a specific version, no action is required — your pipelines are already using the updated image.
Posted Apr 19, 2026 - 08:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2026 - 08:17 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 19, 2026 - 07:20 PDT

Investigating

We are currently investigating this issue.
Posted Apr 19, 2026 - 07:09 PDT
This incident affected: Prod 4 (Infrastructure as Code Management (IaCM)), Prod Eu1 (Infrastructure as Code Management (IaCM)), Prod 1 (Infrastructure as Code Management (IaCM)), Prod 3 (Infrastructure as Code Management (IaCM)), and Prod 2 (Infrastructure as Code Management (IaCM)).