SEI - Team Settings and Efficiency Insights Inaccessible

Incident Report for Harness

Postmortem

Summary

Customers in the Prod2, Prod3, and EU production clusters experienced page load errors when accessing Team Settings, Efficiency Profiles, and Efficiency Insights during a limited window on February 12, 11:30 PM PST to February 13, 2:21 AM PST.

No customer data was lost. Data ingestion, processing, and other core product capabilities remained fully operational throughout the incident. SEI 1.0 customers were not impacted.

Root Cause

During a production deployment, Harness team identified a process bug in the migration step. As a result, the application and database schema became temporarily out of sync. This schema mismatch caused specific pages (Team Settings, Efficiency Profiles, and Efficiency Insights) to fail to load properly.

Impact

The following functionalities were impacted during the incident window:

  • Team Settings
  • Efficiency Profiles
  • Efficiency Insights

Users attempting to access these areas experienced page load errors.

Duration:
February 12, 11:30 PM PST – February 13, 2:21 AM PST

What was not impacted?

The following systems and capabilities remained fully operational:

  • Data ingestion and processing
  • Productivity Insights
  • BA Insights
  • AI Insights
  • Integrations
  • Org tree and other metadata operational flows
  • Customers using SEI 1.0

No customer data was lost.

Remediation

The issue was resolved by executing the required database migration procedure in the production environment, restoring synchronisation between the application and database.

Action Items

To prevent recurrence and strengthen reliability, we are implementing the following improvements:

1. Full Automation of Database Migrations

All production database migration steps will be integrated into our CI/CD deployment pipeline, eliminating manual execution and reducing the risk of human error.

2. Functional Automation and Monitoring

We are converting schema validation into automated functional test coverage.

This ensures that any application–database mismatch is detected immediately during deployment.

4. Strengthened Deployment Checkpoints

We are enhancing our post deployment automation to detect and prevent such issues.

Posted Feb 20, 2026 - 11:06 PST

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 02:21 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2026 - 02:10 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 12, 2026 - 23:15 PST

Investigating

On February 12-13, 2026, the Software Engineering Insights (SEI) module experienced a service disruption lasting approximately 3.5 hours. During this period, users were unable to access team settings, efficiency profiles, and efficiency insights features.
Posted Feb 12, 2026 - 22:51 PST
This incident affected: Prod Eu1 (Software Engineering Insights (SEI)), Prod 2 (Software Engineering Insights (SEI)), and Prod 3 (Software Engineering Insights (SEI)).